Contributions Pilot Systems
 
You are here: Home Extensions Plone Plone Gazette Releases Plone Gazette 3.0 (Release candidate)
Document Actions

Plone Gazette 3.0 (Release candidate)

Up to Product page

This is not a final release. Experimental releases should only be used for testing and development. Do not use these on production sites, and make sure you have proper backups before installing.

Version compatible uniquement avec Plone 3.0

For additional information about this project, please visit the project page.

Available downloads

Release Notes

Tested with Plone 3
State Release candidate
License GPL

Consulter le README.txt pour l'installation générale et le guide d'utilisation, voir UPGRADE.txt pour les notes relatives à une mise à jour.

Change log

RC2

  • Ajout de l'élément manquant i18n:domain à browser/configure.zcml [hannosch]
  • Correction de getUrl -> getURL [naro]

RC1

  • correction de l'erreur d'attribut lors de l'accès au contenu du dossier NewsletterBTree (#30)
  • correction de l'erreur UnicodeError quand à l'activation le sujet ou corps de texte contient des caractères non ascii.
  • PG est enregitré dans toutes les couches de skins.
  • Changement du catalogue d'abonnés. Le Catalogue est basé sur l'outil de catalogue CMFCore et non plus sur ZCatalog.

Bêta 2

  • Correction de l'initialisation du catalogue d'abonnés. Merci à Wouter Vanden Hove.

Bêta 1

  • Le seul changement majeur apporté par rapport à la version 2.5 est la création d'un catalogue d'abonnés dans les objets NewsletterTheme. Tous les abonnés sont stockés dans suscribers_catalog pour être aisément et rapidement trouvés et listés.
  • Les types de contenus sont encore basés sur CMF, le code n'est pas poli ni optimisé.
  • Retrait du dossier /Extensions, ajout d'un profil GS basique comprenant types de contenus et couches de skin.
  • Utilisation de secureSend. Les emails sont générés comme des instances email.Message.message et non comme des strings. Merci à Katja Süss (CroJeWe).
  • Les manipulations de formes et d'objets sont rendues compatibles avec Plone 3.0.
  • Coupure de la version compatible avec Plone 3.0, abandon de la compatibilité avec Plone 2.1 et 2.5. Si vous voulez utiliser PloneGazette dans Plone 2.5, utilisez les versions de la branche 2.5 du produit PloneGazette.

 

 

 

 

by laurent — last modified 2008-07-03 14:04
Contactez-nous

01 44 53 05 55

 
Plan du site
Sites
  © 1999-2018 Pilot Systems - Powered by Plone 82 rue de Pixérécourt, 75020 Paris
France — 01 44 53 05 55